NOT ENTITLED or NOT FOUND returned for valid tickers using the Universal Snapshot endpoint

Incident Report for PolygonIO

Resolved

This incident has been resolved.
Posted Aug 26, 2025 - 14:27 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 26, 2025 - 13:16 EDT

Investigating

The issue with Options is resolved but we are aware their are now issues with certain delayed products using the Universal Snapshot endpoint for stocks.
Posted Aug 26, 2025 - 13:06 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 26, 2025 - 12:56 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 26, 2025 - 12:21 EDT

Investigating

We are investigating and issue where valid Options Contracts queried through the `v3/snapshot` endpoint return NOT ENTITLED. At the moment, it appears isolated to this single endpoint for Options.
Posted Aug 26, 2025 - 12:01 EDT
This incident affected: Options (Market Data REST Endpoints).